jueves, 29 de julio de 2010

VMware vSphere 4.1: Issues luego de migrar vCenter Server


En general, la migración de vCenter Server a la versión 4.1 no genera mayores complicaciones, sin embargo se han reportado algunos problemas los cuales hasta ahora no tienen una solución "oficial" de parte de VMware.

1) Luego del Upgrade a la versión 4.1 de vCenter Server, se produce un error en el Converter Health Status en la sección vCenter Services Status. No obstante este error no impide el normal funcionamiento de vCenter Converte ni otra funcionalidad de vCenter Server. Hasta ahora no ha habido una solución oficial a este problema.
Este error esta reportado en las comunidades de VMware en el link http://communities.vmware.com/thread/276101 y se mantiene sin solución hasta ahora.

Actualizado: Este error ha sido solucionado luego de la publicación del KB-1025010.

2) Luego del Upgrade a la versión 4.1 de vCenter Server se han presentado fallas en los agentes HA en los hosts pertenecientes a un cluster HA. En mi caso este problema se produjo en hosts con versión ESXi 4.0. Los hosts con versiones ESX 3.x y superior no me produjeron problemas luego del upgrade de vCenter.
Para este segundo issue hay dos formas de solución, una más intrusiva que otra. A continuación el detalle para cada una:
  • Opción 1


    • Deshabilitar HA en el cluster HA afectado
    • Esperar a que HA sea removido desde todos los hosts en el cluster
    • Re-habilitar Ha en el cluster.
  • Opción 2


    • Deshabilitar HA en el cluster HA afectado
    • Poner el host en modo de Mantención
    • Remover el host del cluster
    • Remover el host de vCenter Server (removerlo, no solo desconectarlo). Esto es necesario para que se desinstale el agente vCenter
    • Conectarse a la consola del host (Al ser ESXi esto debe ser con acceso directo al servidor).
    • Resetear la configuración del sistema a sus valores por defecto y dejar que el servidor se reinicie
    • Reconfigurar la password Root y la red de administración.
    • Agregar el host a vCenter
    • Configurar el host (Red, seguridad, etc.)
    • Agregar el host nuevamente al cluster, lo que restaurará el agente HA.
La opción más sencilla y menos intrusiva es la opción 1, sin embargo no a todos les ha funcionado según lo reportado en la siguiente discusión en las comunidades VMware: http://communities.vmware.com/message/1570813. En mi caso particular, la opción 1 no me fue de utilidad, por lo que tuve que ejecutar el proceso indicado en la opción 2, lo cual es basicamente reconfigurar un ESXi desde cero. Quizas esto se pueda ver facilitado con la funcionalidad de Host Profile de vCenter 4.x.

Esperemos que pronto haya algún articulo oficial de VMware que nos permita solucionar ambos issues de una manera menos intrusiva.

Reacciones:

0 comentarios:

Publicar un comentario